返回列表 发帖

[软件故障] “Silverlight已被阻止,因为它已过时需要更新。”的解决方法

现象:打开OA中的PDF链接时提示:
“Silverlight已被阻止,因为它已过时需要更新。”


解决:
方法一:关闭这个提示。
cmd下运行以下代码:
  1. reg add "HKCU/Software/Microsoft/Windows/CurrentVersion/Policies/Ext" /v VersionCheckEnabled /t REG_DWORD /d 0 /f
复制代码
经测试重启浏览器后就生效。
方法二:删除更新版本判断用的versionlist.xml,并禁用versionlist.xml更新
cmd下运行以下代码:
  1. del /q "%LOCALAPPDATA%/Microsoft/Internet Explorer/VersionManager/versionlist.xml"reg add "HKCU/Software/Microsoft/Internet Explorer/VersionManager" /v DownloadVersionList /t REG_DWORD /d 0 /f
复制代码
经测试重启浏览器后就生效。
方法三:加入受信任的站点。
在IE浏览器的 Internet选项->安全->受信任的站点,添加有该提示的相关网站。


个人推荐使用方法二,因为不知道是错觉,还是真是情况,发现用方法二屏蔽掉提示之后,IE8浏览器打开网页,以及滚动网页页面木有那么卡了……
欢迎光临:逐梦论坛

返回列表

Powered by Discuz! 7.2   论坛QQ群:逐梦论坛群

© 2001-2021 Comsenz Inc. 本站服务器由0634云主机提供 鲁公网安备 37120302000001号